IP アドレス検索

IP WHOIS 検索:IP アドレスの範囲と登録組織を調べる

IP WHOIS 検索では、アドレス範囲、登録組織、国、管理機関、公開されている技術・不正利用窓口を確認できます。

IP 検索で確認できる情報

  • IP アドレスを含むアドレス範囲と CIDR ブロック。
  • レジストリが公開しているネットワーク名と登録組織。
  • 登録情報上の国と地域インターネットレジストリ(RIR)。
  • レジストリが公開している不正利用通報窓口と技術連絡先。

IP アドレスは誰が分配するのか

IANA は IP アドレスのプールを RIR に分配します。5 つの RIR は AFRINIC、APNIC、ARIN、LACNIC、RIPE NCC です。

  • APNIC はアジア太平洋地域を担当し、国別インターネットレジストリ(NIR)の一つとして TWNIC を挙げています。
  • TWNIC は IP アドレスの割り振り・割り当て・登録管理を行い、認可した事業者を通じてネットワーク利用者にもアドレスを分配します。

アドレス範囲と組織情報の読み方

APNIC では inetnum が IPv4 のアドレス範囲、inet6num が IPv6 のアドレス範囲を表します。ARIN では NetRange がアドレス範囲、CIDR がその CIDR 表記です。

  • APNIC の netname と ARIN の NetName はネットワーク名を表します。
  • APNIC の descr は説明情報、ARIN の OrgName は組織名を表します。
  • APNIC の last-modified は、データベースオブジェクトが最後に変更された日時です。

IP アドレスを調べる WHOIS と RDAP

WHOIS は TCP ポート 43 を使用します。RDAP の IP ネットワークに対する問い合わせ形式は RFC 9082、JSON 応答形式は RFC 9083 で定義されています。

  • RFC 9224 は権威 RDAP サービスの探索方法を定めています。IP アドレスでは最長一致するプレフィックスを使います。
  • IANA は対応するサービスを探すための RDAP ブートストラップデータを、IPv4 と IPv6 に分けて管理しています。

登録上の国と実際の所在地は別

APNIC の country は admin-c の所在国・地域を表します。RIPE は country から IP の実際の使用国を確実に特定することはできないと明記しています。

  • 登録上の国から、利用者やサーバーの実際の所在地を判断しないでください。
  • APNIC は顧客への割り当て情報を非公開にすることを認めています。その場合は上位プロバイダーの登録情報が返され、個々の利用者を特定できるとは限りません。

プライベートアドレスと特殊用途アドレス

IANA はプライベートアドレスのローカルな利用者を記録していません。例えば、10.0.0.0 の IANA WHOIS レコードはプライベート用途の予約を示すもので、利用者の身元情報ではありません。

  • RFC 1918 の IPv4 プライベートアドレス範囲は 10.0.0.0/8、172.16.0.0/12、192.168.0.0/16 です。
  • 100.64.0.0/10 は RFC 6598 の共有アドレス空間であり、RFC 1918 のプライベートアドレスとは異なります。
  • IPv6 の ::1/128 はループバックアドレス、fe80::/10 はリンクローカルユニキャストのアドレス空間です。

技術連絡先と不正利用通報窓口の探し方

RIPE の tech-c は技術連絡先を、abuse-c は不正利用窓口の連絡先を持つロールオブジェクトを参照します。問題の内容に応じて、登録情報に公開されている連絡先を選んでください。

  • ARIN の WHOIS 記載例では、OrgAbuseEmail が組織の不正利用通報先メールアドレスを表します。
  • 登録情報に ARIN とあっても、ARIN がそのネットワークを運用したり、IP アドレスの利用を取り締まったりしているわけではありません。

IP 検索結果を読む 4 つの手順

  1. IP アドレスを入力する

    上の検索欄に IPv4 または IPv6 アドレスを入力し、エンターキーを押します。

  2. アドレス範囲と組織を確認する

    入力したアドレスについて、アドレス範囲、CIDR、ネットワーク名、登録組織を確認します。

  3. 国情報の意味を確認する

    国の欄は登録情報として読み、利用者の実際の所在地を示す根拠にはしないでください。

  4. 連絡先を選ぶ

    連絡が必要な場合は、問題に応じて公開されている技術連絡先または不正利用通報窓口を選びます。

IP WHOIS 検索のよくある質問

IP WHOIS で個人を特定できますか?

IP WHOIS の結果だけで個人の身元を確認することはできません。APNIC は顧客への割り当て情報の非公開を認めており、その場合は上位プロバイダーの登録情報が返されます。

国の欄は IP の実際の所在地ですか?

いいえ。APNIC の country は管理連絡先の所在国・地域を表します。RIPE も、この欄から IP の実際の使用国を確実に特定することはできないと説明しています。

プライベート IP の利用者が分からないのはなぜですか?

プライベートアドレスは IANA への通知なしに使えるため、IANA はローカルな利用者を記録していません。ただし、10.0.0.0 の IANA WHOIS レコードのように、予約用途の情報が返る場合はあります。

台湾の IP アドレスは誰が管理していますか?

APNIC がアジア太平洋地域を担当し、TWNIC はその NIR の一つです。TWNIC は IP アドレスの割り振り・割り当て・登録管理を行い、認可した事業者を通じてネットワーク利用者にも分配します。

IPv6 も検索できますか?

はい。IPv6 アドレスを入力して検索できます。APNIC の inet6num オブジェクトは IPv6 のアドレス範囲を表し、IANA は IPv6 用の RDAP ブートストラップデータも管理しています。

参考資料

WHOIS.net.tw公開日 更新日